Страницы

понедельник, 3 декабря 2012 г.

Starling framework настройка

Для того, чтобы задействовать в играх возможность использования GPU ускорения есть хороший фреймворк к Stage3D - Starling framework:

Starling Framework Требования

Для работы движка Starling необходим Adobe Flash Player 11 и выше и соответственно ActionScript 3. Также нужен FlexSDK 4.6 и AIR3.2 и выше.

Скачиваем starling framework

Для подключения starling к проекту в FlashDevelop, копируем starling.swc в папку lib проекта и подключаем (Add to library):

Starling Framework - Подключение к проекту FlashDevelop

В свойствах проекта устанавливаем платформу FlashPlayer минимум 11.0 версию:

Starling - Flash Player 11

Рассмотрим подробнее код инициализации starling движка:

Файл класса Main.as:

Файл класса Game.as:
starling.display.Sprite заменяет класс flash.display.Sprite
А также:

starling.events.Event заменяет flash.events.Event
starling.display.Stage заменяет flash.display.Stage
и др.

Комментариев нет:

Отправить комментарий